Message boards : Theory Application : New version v3.03
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Laurence
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 12 Sep 14
Posts: 1064
Credit: 327,341
RAC: 138
Message 4916 - Posted: 24 May 2017, 8:36:47 UTC

We are trying to improve the reliability and robustness of the vboxwrapper. This version has a revised polling function that follows the VBox log file rather than hammering on the showvminfo command every second. Logging messages have also been improved to help get a handle on issues. This release is only for Windows. Please let us know how it goes and report back any issues that you may find e.g. VMs not being cleaned up properly.
ID: 4916 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Crystal Pellet
Volunteer tester

Send message
Joined: 13 Feb 15
Posts: 1180
Credit: 815,336
RAC: 358
Message 4917 - Posted: 24 May 2017, 12:04:46 UTC - in response to Message 4916.  

Please let us know how it goes and report back any issues that you may find ...

I first tried running one and noted that the "Show graphics" port is 7859 (in vbox_webapi.xml).
That was suspect to me and decided to request a second task and indeed that VM got the same portnumber.
Now you are not able to see the graphics from both VM's and more important not the Logs of both machines.

VM1 2017-05-24 11:57:42 (6496): forwarding host port 7859 to guest port 80
VM2 2017-05-24 13:47:33 (3908): forwarding host port 7859 to guest port 80
ID: 4917 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
nikogianna
Project administrator
Project developer
Project tester

Send message
Joined: 21 Feb 17
Posts: 21
Credit: 195,770
RAC: 0
Message 4918 - Posted: 24 May 2017, 12:15:55 UTC - in response to Message 4917.  

Does the same apply to the remote desktop port?
ID: 4918 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Crystal Pellet
Volunteer tester

Send message
Joined: 13 Feb 15
Posts: 1180
Credit: 815,336
RAC: 358
Message 4921 - Posted: 24 May 2017, 16:07:56 UTC - in response to Message 4918.  

Does the same apply to the remote desktop port?

No, they are different (randomly).
ID: 4921 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Magic Quantum Mechanic
Avatar

Send message
Joined: 8 Apr 15
Posts: 750
Credit: 11,604,383
RAC: 1,651
Message 4947 - Posted: 27 May 2017, 21:45:27 UTC
Last modified: 27 May 2017, 21:48:10 UTC

The only problem I had with this version was if I tried suspending tasks and restarting them they would start back over at 0% again BUT keep the time elapsed.

I did it again today after they had about 10+ hours and 45% done and they started over at 0% again.

I will d/l the 3.04 version after midnight since my DSL doesn't like me d/ling those huge vdi's on the 6 pc's I have running these. (and then trying to get those VB's to start before the 20mins since there are about 30 cores)

Edit: I just checked and 2 of them already did the d/l of the 3.04 version but as slows as this dsl is running right now I probably can't start any new tasks for a few hours......
Mad Scientist For Life
ID: 4947 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
nikogianna
Project administrator
Project developer
Project tester

Send message
Joined: 21 Feb 17
Posts: 21
Credit: 195,770
RAC: 0
Message 4948 - Posted: 28 May 2017, 9:13:10 UTC - in response to Message 4947.  

The problem with starting from 0% after suspending and restarting has the same root cause that the web application port problem has. It is all due to a change we made to the checkpointing feature of the wrapper that we don't use. This has been fixed on the 3.04 version and neither the web port nor the restarting should be broken.
ID: 4948 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Theory Application : New version v3.03


©2024 CERN