1) Message boards : ATLAS Application : vbox console monitoring with 3.01 (Message 7988)
Posted 20 Mar 2023 by Richie_unstable
Post:
I would do that but I'm not sure where or how. What keys to press or where to point'n click ?
2) Message boards : Theory Application : New version 5.50 (Message 7987)
Posted 20 Mar 2023 by Richie_unstable
Post:
I fired up a cruncher (Windows host) yesterday after having a pause for a few months.
https://lhcathomedev.cern.ch/lhcathome-dev/show_host_detail.php?hostid=4869

I've been introducing myself to the latest app versions here.

I run 2 CMS tasks. They seem to run okay and validated.

I haven't been able to get any ATLAS tasks so far, despite of trying quite actively since yesterday.

I run some Theory tasks. They seem to run okay and validated. But is running them providing useful information for the developement at the moment ?
Should I preferably run CMS or Theory tasks let's say this week ?

By the way... Is there somekind of a hard limit for concurrent amount of Theory tasks per host ? It seems I'm able to run 4 Theory tasks concurrently but no fifth even if I tried "higher" settings. None are in queue. Only 4 tasks running. I can get additional tasks running but they must be from a different app.

Hey... wait a minute !
Just now while writing this message... I got two ATLAS tasks !
I'll see how they will do.
3) Message boards : ATLAS Application : ATLAS vbox v.1.15 (Message 7683)
Posted 29 Jul 2022 by Richie_unstable
Post:
Not too many tasks available ... Le attività sono basse ... Ich würde sie gerne mehr sehen.
4) Message boards : ATLAS Application : ATLAS vbox v.1.14 (Message 7565)
Posted 7 Jul 2022 by Richie_unstable
Post:
I didn't have VirtualBox Manager or any kind of VirtualBox GUI running while "postponed" occurred for v1.14 (with ATLAS v2.00) .
5) Message boards : ATLAS Application : ATLAS vbox v.1.14 (Message 7554)
Posted 7 Jul 2022 by Richie_unstable
Post:
I encountered that "postponed" problem now for the first time. This task:
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3098089


I aborted that task as there was no real prosessing happening.
Then I clicked "reset" for this project and made sure there were no vdi-images left on the disk. And also VirtualBox Manager didn't show any.

Still, the next task was again postponed straight away:
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3098138
There was one v2.00 task running in parallel at this point.

Command:
VBoxManage -q storageattach "boinc_ff69ef3af1554759" --storagectl "Hard Disk Controller" --port 0 --device 0 --type hdd --mtype multiattach --medium "D:/Boinc_data/projects/lhcathomedev.cern.ch_lhcathome-dev/ATLAS_vbox_1.14_image.vdi"

Output:
VBoxManage.exe: error: Cannot attach medium 'D:\Boinc_data\projects\lhcathomedev.cern.ch_lhcathome-dev\ATLAS_vbox_1.14_image.vdi': the media type 'MultiAttach' can only be attached to machines that were created with VirtualBox 4.0 or later
VBoxManage.exe: error: Details: code VBOX_E_INVALID_OBJECT_STATE (0x80bb0007), component SessionMachine, interface IMachine, callee IUnknown
VBoxManage.exe: error: Context: "AttachDevice(Bstr(pszCtl).raw(), port, device, DeviceType_HardDisk, pMedium2Mount)" at line 776 of file VBoxManageStorageController.cpp

Notes:

Another VirtualBox management application has locked the session for this VM.
BOINC cannot properly monitor this VM and so this job will be aborted.



2022-07-07 03:51:53 (8328): Could not create VM
2022-07-07 03:51:53 (8328): ERROR: VM failed to start
2022-07-07 03:51:58 (8328):
NOTE: VM session lock error encountered.
BOINC will be notified that it needs to clean up the environment.
This might be a temporary problem and so this job will be rescheduled for another time.
6) Message boards : ATLAS Application : ATLAS vbox v.1.14 (Message 7552)
Posted 6 Jul 2022 by Richie_unstable
Post:
I encountered that "postponed" problem now for the first time. This task:
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3098089

"Postponed" had happened while that task was running parallel to one LHC@home ATLAS v2.00 task.
I suspended both tasks, shutdown Boinc, restarted Boinc and resumed both tasks. This v1.14 task then started all over from the beginning. It's making progress again.
7) Message boards : ATLAS Application : ATLAS vbox v.1.14 (Message 7543)
Posted 5 Jul 2022 by Richie_unstable
Post:
It seems a bit challenging to get these tasks at the moment. Could you make a bunch of them available again... ? Thanks
8) Message boards : ATLAS Application : ATLAS vbox v.1.13 (Message 7514)
Posted 5 Jul 2022 by Richie_unstable
Post:
I run 125 tasks so far using mainly two hosts (number 1 & 2 on the list below). No problems of any kind. "HITS file was successfully produced" every time.
Tested configurations (tasks running parallel and cores per task) 1 x 1 core, 2 x 1 core, 2 x 2 cores, 3 x 2 cores ... depending on the RAM available.
I didn't have any other kind of tasks running at the same time.

Host 1 : Boinc 7.20.1 , VirtualBox 6.1.34 , Windows 11 , Intel Xeon X5660 overclocked to 3.8 GHz , 16 GB RAM
Host 2 : Boinc 7.20.1 , VirtualBox 6.1.34 , Windows 10 , Intel Xeon X5650 overclocked to 3.9 GHz , 12 GB RAM
Host 3 : Boinc 7.20.1 , VirtualBox 6.1.34 , Windows 10 , Intel Xeon X5660 overclocked to 3.8 GHz , 48 GB RAM
Host 3 : Boinc 7.20.1 , VirtualBox 6.1.34 , Windows 7 , Intel Core 2 Quad Q9550 overclocked to 3.5 GHz , 8 GB RAM

Alles funkzionieren magnifico with this ATLAS edizione v1.13 und that software combination even though those chips are molto vecchio already (launched in 2010 / 2008).

I'll continue now by running this v1.13 parallel to v2.00 (LHC@home) on hosts 1 & 2 to look for signs of weird behaviour.
1 x 2 cores + 1 x 2 cores ... and ... 1 x 1 cores + 1 x 1 cores
* The first v1.13 tasks running parallel to v2.00 on both hosts completed, der Ausgang ist gut.
9) Message boards : CMS Application : New Version 60.60 (Message 7433)
Posted 25 Jun 2022 by Richie_unstable
Post:
Might be a firewall issue.


computezrmle, thanks again for that guru level opinion !
I'm able to confirm now that it was infact an issue with a firewall setting in my cable modem.

I remembered that I had changed the 'Firewall Protection' setting from 'Low' to 'Medium' some time ago. And I hadn't run any LHCathome-dev or LHC@Home tasks after making that change, until this week.

I don't know what those different levels (Low, Medium, High) actually change under-the-hood on the 'Firewall Protection'. There's no information about that. Only this: "This setting helps protect your network from denial of service (DoS) attacks and other common Internet attacks."
There's also additional settings for the 'Firewall' : IPv6 Firewall Protection, Block Fragmented IP Packets, Port Scan Detection, WAN Blocking.
These can be OFF or ON, but their settings don't seem to change by adjusting the 'Firewall Protection' level. I hadn't changed them. They have been ON all the time.

With 'Firewall Protection : Medium' I had problems with 100% of the CMS and ATLAS tasks from both LHCathome-dev and LHC@Home on both of my hosts (W10 and W11).

ATLAS example : https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3094625
CMS example : https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3094303

And after I made that change from 'Medium' back to 'Low' ... all problems were gone immediately:

ATLAS example : https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3095229
CMS example : https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3094836

This was a new thing for me as I hadn't noticed any differences while using my internet connection outside these projects. Logging in on various services, streaming and everything else had worked without problems with 'Medium' too.
10) Message boards : CMS Application : New Version 60.60 (Message 7382)
Posted 17 Jun 2022 by Richie_unstable
Post:
The bad news:
There are lots of network errors when the bootstrap script from inside the VM sends some network tests.
Might be a firewall issue.


Okay, I believe you are right.

I fired up another host that run Windows 10 + Boinc 7.20.0 + VirtualBox 6.1.34. This host too produced the same errors:
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093178

Then I downgraded Boinc from 7.20.0 to 7.16.20. Same errors again.
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093397

Then I downgraded VirtualBox from 6.1.34 to 6.1.32 . Same errors again.
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093379

2022-06-17 20:05:13 (4272): VM Completion Message: Could not connect to all required network services

I wish I knew what to change and where. But I think I'll just pause trying these CMS tasks for now so that I won't flood this board with my messages. This network thing seems to be a problem on my hosts only.
11) Message boards : CMS Application : New Version 60.60 (Message 7366)
Posted 17 Jun 2022 by Richie_unstable
Post:
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093277
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093276
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093290
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093339

My host had some sort of problem with all these CMS tasks. But it is running Boinc 7.20.0 (Development version) + Windows 11 + Virtualbox 6.1.34
... so maybe that has something to do with it. Or is it clearly something else ?


ATLAS tasks had "Outcome : Success"...
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3093565

... but
Run time 24 min 48 sec
CPU time 2 min 35 sec
... and "No HITS file was produced" for all three of them and these lines in Stderr output :

2022-06-17 02:07:07 (2204): Guest Log: *** Job finished ***
2022-06-17 02:07:07 (2204): Guest Log: *** The last 20 lines of the pilot log: ***
2022-06-17 02:07:07 (2204): Guest Log: *** Error codes and diagnostics ***
2022-06-17 02:07:07 (2204): Guest Log: "exeErrorCode": 65,
2022-06-17 02:07:07 (2204): Guest Log: "exeErrorDiag": "Non-zero return code from EVNTtoHITS (33); Logfile error in log.EVNTtoHITS: \"IOVDbSvc FATAL Conditions database connection COOLOFL_TRT/OFLP200 cannot be opened - STOP\"",
2022-06-17 02:07:07 (2204): Guest Log: "pilotErrorCode": 1165,
2022-06-17 02:07:07 (2204): Guest Log: "pilotErrorDiag": "Local output file is missing"


Theory task run without problems.
https://lhcathomedev.cern.ch/lhcathome-dev/result.php?resultid=3092782
12) Message boards : ATLAS Application : ATLAS native 1.07 and vbox 1.08 (Message 7282)
Posted 22 Dec 2021 by Richie_unstable
Post:
Can you tell me the size of the vdi for this Windows version?

Looks like it's 2.47 GB ... (ATLAS_vbox_0.84_image.vdi)
13) Message boards : ATLAS Application : ATLAS native 1.07 and vbox 1.08 (Message 7280)
Posted 22 Dec 2021 by Richie_unstable
Post:
Vbox 1.08 (Windows)

That version seems to be working well too. HITS files got successfully produced so far.
(running Virtualbox 6.1.30, Boinc 7.16.20, Windows 11)



©2023 CERN